No Flag tizianomere
Crossbow
Posts: 33

03 Dec 2017, 22:26

Hi all guys , i changed my modem and i got Telecom fibra new modem. Now i can t join games. Anyone have same problem? How can i resolve it? I speak expecially to italians:) thx all!
User avatar
United States of America musketeer925
ESOC Dev Team
Donator 01
Posts: 1461
ESO: musketeer925

03 Dec 2017, 22:29

Check out suggestions in this thread:

viewtopic.php?f=65&t=12902

"Failed to join" is a pretty common problem.
No Flag tizianomere
Crossbow
Posts: 33

03 Dec 2017, 23:17

Thx, i just checked the forum but there Is a solution that work well. I tryed to read veni s guide and i followed every step but still doesn t work. Vpn doesn t work too. I m just trying to contact italian guys that can have my router to ask questions because im pretty sad. I litterally can t play the game:(
No Flag tizianomere
Crossbow
Posts: 33

04 Dec 2017, 08:55

How to solve the problem : just set up a broadband connection, and lounch the game with it active and all works well :)
User avatar
Sweden Gendarme
ESOC Dev Team
Donator 02
Posts: 2370
ESO: Gendarme

04 Dec 2017, 09:06

I don't think anyone would ever not have a broadband connection.
duck wrote:man it really sucks when you have to agree with gendarme on things
No Flag tizianomere
Crossbow
Posts: 33

04 Dec 2017, 12:50

So noone have "fail to join problems"? I have red many post about it!

Forum Info

Return to “Tech Support”



Who is online

Users browsing this forum: No registered users and 1 guest