No Flag Fr33StYl3R
Crossbow
Posts: 1
ESO: Fr33StYl3R

26 Dec 2018, 20:21

Hello.
I just bought AoE3 Complete Collection today with my brother and a friend.
When we tried to play online, we had issues.
Me and my brother are playing on the same connection so when I host, my brother is able to join but my friends cant.
When my friend host, me and my brother cant join.

What can I do to fix this? Im familiar with port forwarding, my worries about that are: if I port forward I can play with my friend but can my brother also join?

PS: I dont want to use a VPN.

Thanks for any help.
User avatar
Bavaria scarm
Crossbow
Posts: 38
ESO: generalcampo

27 Dec 2018, 11:00

You could go and check your firewallsettings. Also restarting your router could work. Sometimes slots in a multiplayergame also bug out (when multiple people are trying to join simultaneusly), you can refresh a bugged slot like that by adding an AI player and kicking it again. Leaving ESO and relogging in can also work.
User avatar
Spain Snuden
Jaeger
Posts: 2683
ESO: Snuden
Location: x666 HQ

27 Dec 2018, 11:07

Once you have pulled out all your hair in frustration, go download Windscribe VPN (free plan) And connect to any game you want.
Just dont browse any sites with the VPN on as it will drain your free GB's very fast.
36: This herd, was not herded correctly towards his town center
No Flag SNake38
Crossbow
Posts: 14

05 Jan 2019, 21:31

If you have Hamachi installed, uninstall it !
User avatar
Mexico Kikematamitos
Musketeer
Posts: 74
ESO: Kikematamitos
Location: Estados Unidos Mexicanos

08 Jan 2019, 07:25

I have the same problem actually, i fix it opening ports before but my actual Huawei router is very hard to understand how to open ports there.
Image

Forum Info

Return to “Tech Support”



Who is online

Users browsing this forum: No registered users and 1 guest