Andorra flutelrut
Posts: 5
ESO: Flutelrut
Location: Barcelona

15 Feb 2017, 10:15

Yesterday I tried to install aoe3 in two ways: Parallels and Crossover. In Parallels way, installed successfully without any problem. But it does not convince me for the lag resulting.

On Crossover mode, I install following the hellotisue guide (at the top of this thread) with eitheror advice about sound and graphic problems found in Codeweaders forum:
"Install Steam on a new Bottle using the Steam Crosstie. Then install Visual C++ 6.0 Redistributable, Microsoft XML Parser 4.0. Then go into Manage Bottles... and clic on the control panel tab and open Wine Config. Clic on the Libraries tab, and add 2 overrides: dsound (native, built in) and (native, built in). All those solve the DirectX reinstall issue, the blank error window issue, the sound issue, the video playback issue and the cd key dll issue." I attached a screenshot (sorry, catalan language).

Then, I need to disable "Performance Enhanced Graphics" for graphic bugs in AOE3 bottle.
It works well for me, but I can't join to games hosted by others. Maybe because not fixed my internal ip on my mac for port forwarding router. I try today to fix it.

The lag on crossover (v15) is lower than Parallels option, close (but not the same) to bootcamp option (best, on my computer).

I have iMac i5 2.66 Ghz with 20Gb Ram, mid2011 model.

Thanks a lot to @hellotissue for guide!
Captura de pantalla 2017-02-15 a les 10.37.11.png
adding library overrides on control panel Crossover
Captura de pantalla 2017-02-15 a les 10.37.11.png (32.86 KiB) Viewed 1311 times
No Flag ronsu
Posts: 45

15 Feb 2017, 11:39

Interesting! But I'm guessing that, still, the best option is to run Windows with Bootcamp. Isn't it?
France lylife168
Posts: 1

25 Jun 2017, 15:13

Hi !

I just install Steam on my mac with Play On Mac.
Then I install AoE 3, but when I want to play It doesn't work ! That say they can't found the DLL ... I'm really bad with all of this, can you help me ??
Thank you :D

User avatar
New Zealand JakeyBoyTH
Posts: 1761
ESO: Ex-Contributor
Location: New Zealand
Game: AoE Online

25 Jun 2017, 15:34

Please see viewtopic.php?f=65&t=11286 for an alternative solution.
Advanced Wonders suck

- Aizamk

Ugh Advanced Wonders suck

- Aizamk
New Caledonia kimjunun
Posts: 4
ESO: Kimjunun

29 Jun 2017, 17:35

awesome man thanks
Nigeria jgals
Posts: 287
ESO: jgals

03 Apr 2018, 00:04

illusioNtEk wrote:Cant you guys just get bootcamp and run AoE3 with Windows ??

If you want to pay hundreds of dollars
Brazil palmerense1992
Posts: 4

02 May 2018, 19:44

well, i used this guide to install AOE through Steam on my mac. And it worked perfectly ... yw&index=1

Its in spanish, i dont speak spanish, but it's understandable. Just follow the steps and enjoy.
Idk how to use the ESOC Patches on mac though, if anyone could present a guide, that'd be great!

Hope the video will help some of you out
User avatar
United States of America XeeleeFlower
ESOC Community & Media Team
Donator 10
Posts: 558

11 May 2018, 07:21

JakeyBoyTH Guide to playing Age Of Empires III on a Mac

JakeyBoyTH wrote:This is much better than anything else really out there for performance. It is higher performance than WineSkin or other alternatives.

- Wine (make sure to install 32-bit, the development is preferred but not necessary) []
- XQuartz []
- Gatekeeper must not be set to block unsigned packages

This is a guide from [] with annotations from me.

What works

Everything. Without the CD.
Simply copy C:/Program Files/Microsoft Studios into your ~/.wine/drive_c.
Then open age3y.exe.
[Ignore all of this and install steam, simply by clicking the steam.exe install you can download from the steam website. This all works fine and install Age Of Empires III complete collection from steam]
Please note that sound and video may have problems at first, but in my experience after leaving the game running and opening it a few times, it eventually fixes itself. [This fix still works well]
However this may have simply been the remedies below taking a long time to take effect.
Until then, turn your graphics down, down, down (for me it was shaders to low, though now no longer :)) until you can actually see something.
[Sometimes high shaders cause problems but that seems to be fixed. This can solve graphical issues however]

What does not

• mfc42.dll, quartz.dll, and d3dx9_36.dll are needed in Windows/System32, but in this wine version all i found missing was mfc42. Override it to "Native" in wine config.
• [This is not necessary for the steam install, as long as you have the Windows XP compatibility mode on you should be ok]
• Your product key may not fit in the initial dialog due to a font bug. To make it work, simply install the missing font with:
winetricks corefonts
[It should work fine]
• Although the sound works at first, if you ignore the "missing" prompt, it may stop. In this case:
[Even when this error came up I was able to ignore it and the sound worked fine, however this fix will still work]
There are a few ways you are able to get this file. Choose one of the following:
1 Copy the file from an existing Windows install (C:\WINDOWS\SYSTEM32)
2 Copy it from a Windows XP install cd by issuing the following command "wine d:/i386/expand.exe d:/i386/l3codecx.ax_ h:/.wine/" assuming wine has d:/ mapped to a cd drive with a Windows XP install cd and h:/ is mapped to your home directory.
3 Install a codec pack with the file:
4 -Download this file.
5 -Run BCM1043.exe with wine, it will ask for installing Gecko HTML engine too, install it. After installing, it will create a folder called ~/.wine/drive_c/Program Files/BCM/. Copy the file under 'Codecs/DIRECTS/Fraunhofer/' to ~/.wine/drive_c/windows/system32/.
Method 3 worked fine for me. All you have left to do is run:
wine regsvr32
[Overall, the steam install is really plug and play with Steam. Sometimes it freezes or the screen gets resized, simply tab in and out and it should work. The more successful runs the program has the better it will run]

WINE has come a long way and the install should work great. I followed this guide on a clean OS, High Sierra with no issues. Remember 32-bit WINE and the development build (3.7) is best for compatibility and performance as there was some Direct3D compatibility
in the 3.3 update which worked well and improved a lot.

Can I play EP with this?
No, EP for the mainstream Mac community is dependent on WINE supporting NET 4.1, which it won’t for the foreseeable future. There are no workarounds.

I have issues - who do I tell?
If you ask a staff member who is nice enough to forward it on to JakeyBoyTH in the ESOC discord, or mention him yourself in the ESOC discord server. I will add your issue and the fix to this document.
My posts represent my views and may or may not represent the views of ESOC as a whole.

Whether or not it is clear to you, no doubt the universe is unfolding as it should.

I love good methamphetamine; highly addictive.
User avatar
France Rikikipu
ESOC Dev Team
Posts: 1516
ESO: p-of
Location: In your base

11 May 2018, 08:01

I didin't pay attention when I made it, but by reading Jakey post, it seems that mac and linux installation works exactly the same way.

As stated in esoc-patch.php EP works on Mac

Forum Info

Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 1 guest